Kaos LiFePO4 electrical system v1

These seem like revision 2 or 3 of the various instructions and manuals that I have used before to set the Wakespeed stuff up.

You can use a USB cable to the port inside the unit and a terminal program (putty on Windows, iTerm/terminal on Mac) to configure things using the command line, a 3rd party piece of software sold by Off Grid Solutions (or something like that) which does most of it, or the Android app to generate a configuration file.

The USB cable approach requires you understand the complicated syntax and build out your configuration either by hand, or based on a template. It’s very time consuming and prone to error.

The software option is probably the one I used the most, but it’s not always in sync with firmware changes and syntax issues. I’ve ended up with mangled configurations a lot of times. It’s also a very basic piece of software with difficult UX. On top of that, you have to pay for it and it’s not offered nor supported by Wakespeed.

The Android app asks a bunch of questions and spits out a configuration you can then download to the device using a messy USB cable option, or generate a file and push it to the device using Windows and a bunch of batch files and a USB cable. The iOS version when I tested it did only about 50% of the Android one.

The user guide and card is also confusing. You have to set the dip switches for the size of your bank, type of batteries, and other things, but you also really, really should upload a specific configuration based on your battery charge details if you’re using LiFePO4. They used to keep examples of various battery manufacturer profiles on their website - I don’t know if those are around anymore, but I probably have some old copies. You use the Windows batch files and USB cable to upload these.

Any way you slice it, it’s difficult to configure with poor documentation and confusing syntax and approach.

The trick for me was removing the USB device that windows automatically installed and manually putting in drivers that wakespeed provided. Now I can update the firmware again (including through the offgrid software).

1 Like

Great hardware that fills a void. But hampered by its difficultly to set up custom configs. Custom configs is why I bought the WS500. And the documentation… well, I second everything said above. If Dragonfly would hire an experienced tech writer that would be a start.
And yes, I also learned the hard way that you need to use the Windows drivers that are compatible with the WS500.
I just got my boat back in the water and I’m planning on implementing the WS500 to Cerbo GX comm link this spring. So at last, I’m hoping that I can have some visibility into what the WS500 is doing.

1 Like

Ah good note on fixing those drivers. I’ve not had this happen, which is surprising since I’ve worked on my own many, many times, and others as well. Must be super lucky!

I tried the beta version of this and had bad results, but I am looking forward to trying the WS500 again here in a month with that link for the same reason.